Transaction Visibility - Some recent transactions might not be fully visible in the "Transactions"-Tab.

Incident Report for Relai

Monitoring

We have fixed the issue. If you currently still come across, please reach out to support and make sure you are on the newest app-version.
Posted Dec 03, 2025 - 13:20 CET

Identified

We are aware of an issue, where some recent Transactions are not shown in the "Transactions"-Tab. We are working on a fix. It will be released soon. To show all your wallet movements, you can use any Blockchain-Explorer to see the transactions on-chain.
Posted Oct 17, 2025 - 08:53 CEST