Credit Card Payments - Current Issues when trying to buy with credit card.

Incident Report for Relai

Resolved

The issue should be resolved. We have not received any more cases where this happened.
Posted Aug 22, 2025 - 11:42 CEST

Monitoring

The Issue should be resolved. Please reach out to us if you still have troubles buying bitcoin with your credit card.
Posted Aug 14, 2025 - 12:40 CEST

Identified

We currently have an issue with our payment provider that may result in failed buys with credit cards. We have identified the issue, and we are working on a fix.
Posted Aug 14, 2025 - 12:08 CEST